交互式数据分析系统使用手册

界面元素简介

 

菜单与工具栏

 

主菜单和工具栏

主菜单和工具栏

 

菜单包括主菜单和右键菜单,工具栏包括视图工具栏和普通工具栏。

 

主菜单中,File 和 Edit 菜单与市面上其它应用软件的对应的菜单内容相似,主要不一样的地方在于本系统的 File 菜单中包含 Session 项,可以导出系统当前的运行状态(包括界面状态、当前已创建的变量、系统当前的设置等等),也可以通过导入功能恢复以前导出的状态。访问本系统的 Edit 菜单中的 Preferences 项可以调整系统设置。Edit 菜单的菜单项会根据系统界面当前的焦点自动调整,比如当焦点在 Navigator 区域时,所有 Edit 菜单项都是不可用的灰色,但是如果焦点是打开的 python 文件编辑区域,大部分 Edit 菜单项都会变成可用,并且菜单项中多出了一系列文本搜索的功能。

 

主菜单中的 Run 菜单包含了脚本调试和运行的功能,Window 菜单包含了切换和重置视图、打开新区域和缩放界面字体的功能,Tools 菜单包含了插件管理的功能。

 

右键菜单会依据单击时所在的区域或元素弹出可用的菜单项,如果在 Variables 区域中右键单击不同类型的变量,右键菜单中的 Open With 和 Send To 项都会随不同的变量类型更新。

 

工具栏(包括普通工具栏和视图工具栏)中所有的功能都能在主菜单中找到对应。视图工具栏包含了切换和重置视图的功能。普通工具栏会依据不同界面焦点增减功能按钮,但其中只会包含 File、Edit 和 Run 菜单中的功能。

 

视图

 

本系统默认提供三种视图: Welcome 视图、Workbench 视图和 Product Browser 视图,用户可以通过安装插件来添加新的视图。视图是一种界面布局,不同的界面布局适用于不同的使用目的。

 

三种默认视图

三种默认视图

 

Welcome 视图主要包含了软件的简介和主要功能的导航。在系统首次运行时默认显示 Welcome 视图。

 

Workbench 视图是用于数据处理的主要视图,包含了 Navigator 区域、Editor 区域、Tasks 区域、Variables 区域、Outlines 区域、Console 区域、Log 区域和 History 区域。这些不同的区域的功能将在区域小节中介绍。在 Workbench 视图中可以完成数据处理的所有工作,包括输入输出数据、分析和处理数据、绘制曲线,编写、调试和运行脚本。

 

Product Browser 视图主要用于访问数据仓库,包含了 Product Browser 区域、Editor 区域、Console 区域和 Variables 区域。在这个视图中主要完成数据的查询工作。

 

区域

 

本系统默认提供了十一种区域:Product Browser 区域、Product Tree 区域、Navigator 区域、Editor 区域、Tasks 区域、Variables 区域、Outline 区域、Console 区域、Log 区域、History 区域和 PlotXY properties 区域。用户可以通过安装插件添加新区域。

 

Product Browser 区域提供了查询数据的功能,查询结果生成为列表显示的同时还会自动建立名为 QUERY_RESULT 的变量在 Variables 区域中显示,多次查询的结果建立的变量名会如 QUERY_RESULT_1、 QUERY_RESULT_2 等递增。

 

Product Browser 区域

Product Browser 区域

 

Product Tree 区域; TBC

 

Navigator 区域提供了便捷的访问本地文件的方法,将本地文件系统以树形结构显示。用户可以自行将常用的目录添加到 Navigator 区域,以便快速访问。Navigator 目录除了作为浏览文件系统的快捷方式之外,在其中选定的任意项目,无论目录还是文件,都会在 Outline 区域中显示其概要信息,这项功能也可作为数据分析的辅助功能。

 

Navigator 区域

Navigator 区域

 

Editor 区域专用于容纳新建的编辑器或查看器,比如打开或新建一个 Python 脚本或文本文档,打开 FITS 文件,或者是双击查看在命令行或脚本中新建的变量(比如数组)的内容,打开的编辑器或查看器都会出现在 Editor 区域。

 

Tasks 区域容纳了一系列数据分析或处理所需要的任务(典型的任务比如数组运算)。本系统默认提供的任务比较少,这是由于使用本系统的用户有可能来自于各个学科,每种学科所需要的数据处理任务都有差异,如果都混在一起提供,不仅影响系统的易用性,同时还会使系统变得臃肿。本系统对于任务的扩充已提供了易于使用的框架,宇联技术团队在了解数据处理的需求的前提下,有信心满足大多数学科的需要。
Tasks 区域中,任务被组织到三个根节点:Applicable、All 和 By Category。All 根节点容纳了任务的全集,By Category 将任务划分为不同的分组方便用户使用时查找,Applicable 分组则是在用户选定 Variables 区域中某个变量后,系统将所有可应用于当前选定变量的任务归纳到这个分组,极大地提高了本系统的易用性。

 

Variables 区域主要用于列出使用脚本环境(使用命令行或者是运行完整脚本)建立的变量,同时某些任务也会将结果保存为变量(例如查询数据仓库后查询结果会保存到 QUERY_RESULT 变量),用户可以将这个区域看做是数据的可视化的缓存池,任何在分析过程中想要暂时留存作为参照的数据都可以建立变量,在 Variables 区域中选定任何变量都将会在 Outline 区域显示该变量的概要信息,如果双击某个变量,本系统会依据该变量的类型决定是否打开查看器或编辑器,通常情况下,如果一个变量是基础类型(比如整型数,浮点数,字符串等),在 Outline 区域就会显示出所有信息,包括变量的值,所以双击此类变量不会打开查看器或编辑器,如果变量是数组,双击时将会打开列表查看器显示数据的内容。
如前面介绍 Tasks 区域时曾介绍过,在 Variables 区域选定任意的变量,对此变量可用的任务都会归纳在 Tasks 区域中的 Applicable 根节点下。

 

Outline 区域在介绍前述的各个区域时已多次提及,这个区域会显示在其它区域中选定的元素的概要信息,比如 Tasks 区域中选定的任务、Variables 区域中选定的变量、Navigator 区域中选定的目录或文件、列表查看器中选定的列表项等等。本系统也为扩充这个区域的功能提供了易于使用的框架,仅需添加少量代码就可以为一种新型的元素提供支持。

 

Tasks、Variables 和 Outline 区域协作

Tasks、Variables 和 Outline 区域协作

 

Console 区域用于输入脚本以及输出一些文本信息,本系统会将大部分通过界面操作完成的任务的等价的脚本输出在 Console 中,用户可以将这些输出复制粘贴到脚本中使用,以后做相同的操作时可以直接使用脚本而不必多次界面操作了。

 

Log 和 History 区域都用于记录历史信息。Log 区域依据用户设置的日志级别(fine、info 和 warning 等,选定某个级别意味着此级别以上的日志记录,一下的忽略,级别按紧迫性划分,严重的消息级别大)记录本系统的日志;History 区域记录当次系统运行中脚本环境运行过的所有脚本,如果有运行时错误,History 区域会记录下当次错误的堆栈信息,便于发现脚本或系统的潜在问题。

 

PlotXY properties 区域用于调整曲线绘制功能的各种细节,这个区域可以从使用绘制功能后打开的曲线的窗口中的邮件菜单中访问,使用这个区域可以更改曲线图的布局、标题、子标题、图例、曲线等等元素的各个细节,包括位置、线宽、颜色、字体、可见性等等细节。

 

Console、Log 和 History 区域协作

Console、Log 和 History 区域协作

 

编辑器

 

曲线绘制